# CG1018 restarts periodically

## Symptom

Relay Box restarts every 33.3 minutes. Depending on the settings it may result in alarm signal being generated by the unit.

## Cause

There is the following part in the config file.

{% code overflow="wrap" %}

```sh
PING_URL="http://www.google.com"
PING_REATTEMPTS=5
PING_TIMEOUT=20
 
#How many seconds to wait for server to respond before aborting, and how many tries
SERVER_TIMEOUT=1
SERVER_TRIES=8
 
#How many retries of getting data from Service-URL before it reboots 
MAXIMUM_RETRIES_BEFORE_REBOOT=100
```

{% endcode %}

It pings the PING\_URL and reboots the unit after 2000 s if the ping is unsuccesful.

In a network with blocked Internet access, the device will not be able to ping the default PING\_URL which is "<http://www.google.com>" and will reboot regularly.

## Solution

Change the PING\_URL to a URL that can be accessed. Also check if it answers to ping as this can be blocked.

In case you want to use IP enter PING\_URL="<http://IP\\_ADDRESS>" e.g. PING\_URL="<http://192.168.61.252>".


---

# Agent Instructions: Querying This Documentation

If you need additional information that is not directly available in this page, you can query the documentation dynamically by asking a question.

Perform an HTTP GET request on the current page URL with the `ask` query parameter:

```
GET https://help.boomerang3.com/cg1018-relay-box-installation-manual/troubleshooting/cg1018-restarts-periodically.md?ask=<question>
```

The question should be specific, self-contained, and written in natural language.
The response will contain a direct answer to the question and relevant excerpts and sources from the documentation.

Use this mechanism when the answer is not explicitly present in the current page, you need clarification or additional context, or you want to retrieve related documentation sections.
